杭电 GPA

GPA

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1421 Accepted Submission(s): 598
 
Problem Description
Each course grade is one of the following five letters: A, B, C, D, and F. (Note that there is no grade E.) The grade A indicates superior achievement , whereas F stands for failure. In order to calculate the GPA, the letter grades A, B, C, D, and F are assigned the following grade points, respectively: 4, 3, 2, 1, and 0.
Input
The input file will contain data for one or more test cases, one test case per line. On each line there will be one or more upper case letters, separated by blank spaces.
Output
Each line of input will result in exactly one line of output. If all upper case letters on a particular line of input came from the set {A, B, C, D, F} then the output will consist of the GPA, displayed with a precision of two decimal places. Otherwise, the message "Unknown letter grade in input" will be printed.
Sample Input
A B C D F
B F F C C A
D C E F
Sample Output
2.00
1.83
Unknown letter grade in input
Author
2006Rocky Mountain Warmup
Source
HDU “Valentines Day” Open Programming Contest 2009-02-14
Recommend
lcy
 
 
 
 
代码:
 

#include <iostream>
using namespace std;

int main()
{
 char st[100];
 int n, i;
 double sum, flag;

 while (gets(st))
 {
  flag = 1;
  n = strlen(st);
  sum = 0;
  for (i = 0; i < n; i++)
  {
   if (st[i] == ' ')
    sum += 0;
   else if (st[i] == 'A')
    sum += 4;
   else if (st[i] == 'B')
    sum += 3;
   else if (st[i] == 'C')
    sum += 2;
   else if (st[i] == 'D')
    sum += 1;
   else if (st[i] == 'F')
    sum += 0;
   else
   {
    cout << "Unknown letter grade in input" << endl;
    flag = 0;
    break;
   }
  }
  if (flag)
  {
   cout.setf(ios::fixed);
   cout.precision(2);
      cout << sum / ((n + 1) / 2) << endl;
  }
 }

 return 0;
}

 
经验总结:
     1.一组花括号内,break放到最后。
     2.一些有可能会用的模块,用flag来标记,决定是否调用

本文章迁移自http://blog.csdn.net/timberwolf_2012/article/details/7646378

/** * RECOMMENDED CONFIGURATION VARIABLES: EDIT AND UNCOMMENT THE SECTION BELOW TO INSERT DYNAMIC VALUES FROM YOUR PLATFORM OR CMS. * LEARN WHY DEFINING THESE VARIABLES IS IMPORTANT: https://disqus.com/admin/universalcode/#configuration-variables*/ /* var disqus_config = function () { this.page.url = PAGE_URL; // Replace PAGE_URL with your page's canonical URL variable this.page.identifier = PAGE_IDENTIFIER; // Replace PAGE_IDENTIFIER with your page's unique identifier variable }; */ (function() { // DON'T EDIT BELOW THIS LINE var d = document, s = d.createElement('script'); s.src = 'https://chenzz.disqus.com/embed.js'; s.setAttribute('data-timestamp', +new Date()); (d.head || d.body).appendChild(s); })();